GNS3 Labs: Dynamic IPsec VPNs and NAT across BGP Internet routers: Answers Part 2

Can you complete this Dynamic, IPsec, NAT& BGP lab? GNS3 Topology: https://goo.gl/tPAcjd
Get the VPN Config Generator and all my videos as part of a subscription here: https://goo.gl/mJMZGW
Cisco documentation: https://goo.gl/hjmdFR

For lots more content, visit http://www.davidbombal.com – learn about GNS3, CCNA, Packet Tracer, Python, Ansible and much, much more.Can you complete this Dynamic, IPsec, NAT& BGP lab? GNS3 Topology: https://goo.gl/tPAcjd
Get the VPN Config Generator and all my videos as part of a subscription here: https://goo.gl/mJMZGW
Cisco documentation: https://goo.gl/hjmdFR

For lots more content, visit http://www.davidbombal.com – learn about GNS3, CCNA, Packet Tracer, Python, Ansible and much, much more.

! ========================================================
! Code created by Network Experts Limited !
! Find us at www.ConfigureTerminal.com !
! ========================================================
! CONFIG FOR: c1.davidbombal.com !
! ========================================================

access-list 100 remark ****** Link to c2.davidbombal.com ******
access-list 100 permit ip 10.1.1.0 0.0.0.255 10.1.2.0 0.0.0.255
!
access-list 101 remark ****** NAT ACL ******
access-list 101 deny ip 10.1.1.0 0.0.0.255 10.1.2.0 0.0.0.255
access-list 101 permit ip 10.1.1.0 0.0.0.255 any
!
ip nat inside source route-map nonat interface G0/1 overload
!
route-map nonat permit 10
match ip address 101
!
crypto isakmp policy 10
hash md5
authentication pre-share
encryption 3des
group 2
lifetime 86400
!
crypto isakmp key cisco123 address 0.0.0.0 0.0.0.0
crypto isakmp key cisco123 hostname c2.davidbombal.com
!
crypto ipsec transform-set myset esp-3des esp-md5-hmac
mode tunnel
!
crypto dynamic-map dynmap 120
description ****** Dynamic Map to c2.davidbombal.com ******
set transform-set myset
set pfs group2
match address 100
set security-association lifetime seconds 86400
set security-association lifetime kilobytes 4608000
!
crypto map mymap 130 ipsec-isakmp dynamic dynmap
!
crypto map mymap 110 ipsec-isakmp
description ****** Static VPN MAP to c2.davidbombal.com ******
set peer c2.davidbombal.com dynamic
set transform-set myset
set pfs group2
match address 100
set security-association lifetime seconds 86400
set security-association lifetime kilobytes 4608000
!
interface G0/1
crypto map mymap
ip nat outside
!
interface G0/0
ip nat inside

! ========================================================
! Code created by Network Experts Limited !
! Find us at www.ConfigureTerminal.com !
! ========================================================
! CONFIG FOR: c2.davidbombal.com !
! ========================================================

access-list 100 remark ****** Link to c1.davidbombal.com ******
access-list 100 permit ip 10.1.2.0 0.0.0.255 10.1.1.0 0.0.0.255
!
access-list 101 remark ****** NAT ACL ******
access-list 101 deny ip 10.1.2.0 0.0.0.255 10.1.1.0 0.0.0.255
access-list 101 permit ip 10.1.2.0 0.0.0.255 any
!
ip nat inside source route-map nonat interface G0/1 overload
!
route-map nonat permit 10
match ip address 101
!
crypto isakmp policy 10
hash md5
authentication pre-share
encryption 3des
group 2
lifetime 86400
!
crypto isakmp key cisco123 address 0.0.0.0 0.0.0.0
crypto isakmp key cisco123 hostname c1.davidbombal.com
!
crypto ipsec transform-set myset esp-3des esp-md5-hmac
mode tunnel
!
crypto dynamic-map dynmap 120
description ****** Dynamic Map to c2.davidbombal.com ******
set transform-set myset
set pfs group2
match address 100
set security-association lifetime seconds 86400
set security-association lifetime kilobytes 4608000
!
crypto map mymap 130 ipsec-isakmp dynamic dynmap
!
crypto map mymap 110 ipsec-isakmp
description ****** Static VPN MAP to c2.davidbombal.com ******
set peer c1.davidbombal.com dynamic
set transform-set myset
set pfs group2
match address 100
set security-association lifetime seconds 86400
set security-association lifetime kilobytes 4608000
!
interface G0/1
crypto map mymap
ip nat outside
!
interface G0/0
ip nat inside

subscribe
  • David Bombal