GNS3 Labs: DMVPN, IPsec and NAT across BGP Internet routers: Answers Part 7

GNS3 Labs: DMVPN, IPsec and NAT across BGP Internet routers: Answers Part 7

Can you complete this DMVPN, IPsec, NAT& BGP lab? GNS3 Topology: https://goo.gl/udfNPL
Get the VPN Config Generator and all my videos as part of a subscription here: https://goo.gl/mJMZGW
Cisco documentation: https://goo.gl/hjmdFR

For lots more content, visit http://www.davidbombal.com – learn about GNS3, CCNA, Packet Tracer, Python, Ansible and much, much more.

! ======================================================
! Code created by David Bombal !
! Find us at www.davidbombal.com !
! ======================================================
! CONFIG FOR: C1 !
! ======================================================

! HUB SITE !

crypto isakmp policy 10
hash md5
authentication pre-share
encryption 3des
group 2
lifetime 86400
!
crypto isakmp key cisco123 address 0.0.0.0 0.0.0.0
!
crypto ipsec transform-set myset esp-3des esp-md5-hmac
mode transport
!
crypto ipsec profile cisco
set transform-set myset
set security-association lifetime seconds 86400
set security-association lifetime kilobytes 4608000
!
interface Tunnel 111
description ****** DMVPN GRE Tunnel ******
ip address 192.168.1.1 255.255.255.0
bandwidth 1000
delay 1000
ip nhrp holdtime 360
ip nhrp network-id 100000
ip nhrp authentication cisco
ip mtu 1400
ip tcp adjust-mss 1360
ip nhrp map multicast dynamic
tunnel source G0/1
tunnel mode gre multipoint
tunnel key 100000
tunnel protection ipsec profile cisco
no ip split-horizon eigrp 100
no ip next-hop-self eigrp 100
!
router eigrp 100
network 192.168.1.1 0.0.0.0
network 10.0.0.0 0.255.255.255
no auto-summary

!======================================================
! Code created by David Bombal !
! Find us at www.davidbombal.com !
! ======================================================
! CONFIG FOR: C2 !
! ======================================================

! SPOKE SITE !

crypto isakmp policy 10
hash md5
authentication pre-share
encryption 3des
group 2
lifetime 86400
!
crypto isakmp key cisco123 address 0.0.0.0 0.0.0.0
!
crypto ipsec transform-set myset esp-3des esp-md5-hmac
mode transport
!
crypto ipsec profile cisco
set transform-set myset
set security-association lifetime seconds 86400
set security-association lifetime kilobytes 4608000
!
interface Tunnel 111
description ****** DMVPN GRE Tunnel ******
ip address 192.168.1.2 255.255.255.0
bandwidth 1000
delay 1000
ip nhrp holdtime 360
ip nhrp network-id 100000
ip nhrp authentication cisco
ip mtu 1400
ip tcp adjust-mss 1360
ip nhrp nhs 192.168.1.1
ip nhrp map multicast 8.8.3.2
ip nhrp map 192.168.1.1 8.8.3.2
tunnel source G0/1
tunnel mode gre multipoint
tunnel key 100000
tunnel protection ipsec profile cisco
!
router eigrp 100
network 192.168.1.2 0.0.0.0
network 10.0.0.0 0.255.255.255
no auto-summary

subscribe